Running sssu on Fedora

HP's EVA command view linux version can be run on Fedora, even thought it does not seem to be officially supported.

After downloading the Redhat version from HP, I encountered this:-

[andrew@fedora16 sssu]$ ls -l
total 7728
-rw-rw-r-- 1 andrew andrew 7909895 Aug 21 18:41 sssu_linux_x86
[andrew@fedora16 sssu]$ chmod u+x sssu_linux_x86 

[andrew@fedora16 sssu]$ ./sssu_linux_x86 
./sssu_linux_x86: error while loading shared libraries: libstdc++.so.5: cannot open shared object file: No such file or directory

I initially tried creating a symlink but this did not work:-

[root@fedora16 ~]# ln -s /usr/lib/libstdc++.so.6 /usr/lib/libstdc++.so.5

andrew@fedora16 sssu]$ ./sssu_linux_x86 
./sssu_linux_x86: /usr/lib/libstdc++.so.5: version `CXXABI_1.2' not found (required by ./sssu_linux_x86)
./sssu_linux_x86: /usr/lib/libstdc++.so.5: version `GLIBCPP_3.2' not found (required by ./sssu_linux_x86)
[andrew@fedora16 sssu]$ 

[andrew@fedora16 sssu]$ ldd sssu_linux_x86 
./sssu_linux_x86: /usr/lib/libstdc++.so.5: version `CXXABI_1.2' not found (required by ./sssu_linux_x86)
./sssu_linux_x86: /usr/lib/libstdc++.so.5: version `GLIBCPP_3.2' not found (required by ./sssu_linux_x86)
        linux-gate.so.1 =>  (0xb77c3000)
        libpam.so.0 => /lib/libpam.so.0 (0x4104b000)
        librt.so.1 => /lib/librt.so.1 (0x4f5d1000)
        libpthread.so.0 => /lib/libpthread.so.0 (0x4f568000)
        libdl.so.2 => /lib/libdl.so.2 (0x4f561000)
        libstdc++.so.5 => /usr/lib/libstdc++.so.5 (0x4f936000)
        libm.so.6 => /lib/libm.so.6 (0x4f585000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x4f5b2000)
        libc.so.6 => /lib/libc.so.6 (0x4f3b1000)
        libaudit.so.1 => /lib/libaudit.so.1 (0x412e8000)
        /lib/ld-linux.so.2 (0x4f38c000)
[andrew@fedora16 sssu]$

Following a tip from IBM's website, I searched rpmbone for libstdc and CXXABI for Fedora16. This found compat-libstdc++-33.rpm. The contents of it included the missing libraries:-

Provides :
libstdc++.so.5
libstdc++.so.5(CXXABI_1.2)
libstdc++.so.5(CXXABI_1.2.1)
libstdc++.so.5(CXXABI_1.2.2)
libstdc++.so.5(GLIBCPP_3.2)
libstdc++.so.5(GLIBCPP_3.2.1)
libstdc++.so.5(GLIBCPP_3.2.2)
libstdc++.so.5(GLIBCPP_3.2.3)
libstdc++.so.5(GLIBCPP_3.2.4)
compat-libstdc++-33
compat-libstdc++-33(x86-32)

This was downloaded and installed:-

[root@fedora16 sssu]# yum localinstall compat-libstdc++-33-3.2.3-68.1.i686.rpm 
...edited...
Installed:
  compat-libstdc++-33.i686 0:3.2.3-68.1                                                                                 

Complete!
[root@fedora16 sssu]# 

Now to try it again:-

[andrew@fedora16 sssu]$ ldd sssu_linux_x86 
        linux-gate.so.1 =>  (0xb7750000)
        libpam.so.0 => /lib/libpam.so.0 (0x4104b000)
        librt.so.1 => /lib/librt.so.1 (0x4f5d1000)
        libpthread.so.0 => /lib/libpthread.so.0 (0x4f568000)
        libdl.so.2 => /lib/libdl.so.2 (0x4f561000)
        libstdc++.so.5 => /usr/lib/libstdc++.so.5 (0xb7677000)
        libm.so.6 => /lib/libm.so.6 (0x4f585000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x4f5b2000)
        libc.so.6 => /lib/libc.so.6 (0x4f3b1000)
        libaudit.so.1 => /lib/libaudit.so.1 (0x412e8000)
        /lib/ld-linux.so.2 (0x4f38c000)
      

Nothing missing so far….

[andrew@fedora16 sssu]$ 
[andrew@fedora16 sssu]$ ./sssu_linux_x86 


SSSU for HP StorageWorks Command View EVA
Version: 6.0.2 
Build: 5

Manager:gy-sma01.prod.company.net
Username:Administrator
Password:

NoSystemSelected> ls system

Systems available on this Manager:
  Array01
  Array02
NoSystemSelected>

Success!


rb/sssu-runningonfedora.txt · Last modified: 08/07/2019 10:48 by andrew