Cisco layer 3 switching Valid HTML 4.01!

Background

Due to changes in the pricing structure of our WAN telecom links provider, it is cheaper to lease a 10MB/s fibre circuit than a 2MB/s X21 circuit although it is more expensive to setup. Because of this, the last site we have connected uses a 10MB/s fibre. Instead of terminating this on a router, it is terminated on a layer 3 switch, in this case a Cisco 3750.

Configuration

By default, all ports on Cisco switches are connected to VLAN1. In our configuration, port 1/0/24 was placed in to VLAN2. An ip address is allocated to each vlan interface and routing is then enabled between VLANs. After several false starts trying to configure bridge groups (BVI) as would have been done on other, older products, this inter vlan routing worked almost too easily. It was the intention to add some other sites, the next would have been connected to 1/0/23 in VLAN3, but this has not happened yet, so 1/0/23 is left shutdown.
An example config is listed below, several lines have been changed for reasons of confidentiality. The model in question is a 3750 with 24 10/100MB/s ethernet ports and 2 SFP module slots which were fitted with RJ45 1000MB/s modules for connection to some servers.

RRR-3750#sh run 
Building configuration...

Current configuration : 2031 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RRR-3750
!
enable password trytoguessme
!
ip subnet-zero
ip routing
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
!
interface FastEthernet1/0/1
no ip addess
!
interface FastEthernet1/0/2
 no ip address
.
.
.
interface FastEthernet1/0/22
 no ip address
!
interface FastEthernet1/0/23
 description Link to next site
 switchport access vlan 3
 no ip address
 shutdown
!
interface FastEthernet1/0/24
 description Link to RRR via 10MB/s line
 switchport access vlan 2
 mdix auto
 no ip address
 duplex full
 speed 10
!
interface GigabitEthernet1/0/1
 description Link to NetWare 6.5 svrnw65-01
 no ip address
!
interface GigabitEthernet1/0/2
 description Link to Linux mail svrswl-01
 no ip address
!
interface Vlan1
 description Local ethernet
 ip address 192.168.127.1 255.255.255.0
!
interface Vlan2
 description WAN link to RRR
 ip address 192.168.128.2 255.255.255.252
!
interface Vlan3
 description WAN link to next site
 ip address 192.168.128.6 255.255.255.252
!
router eigrp 1
 redistribute static
 network 192.168.127.0
 no auto-summary
 no eigrp log-neighbor-changes
!
ip classless
ip route .0.0.0 0.0.0.0 192.168.127.7
ip http server
!
!
line con 0
 password guessmeaswell
line vty 0 4
 password guessmeaswell
 login
line vty 5 15
 login
!
ntp clock-period 36029231
ntp peer 192.25.0.1
ntp peer 192.25.0.7
ntp server 62.232.4.232
ntp server 62.232.4.233
end

RRR-3750#

Notes:- Several of these units can be stacked so the ethernet ports are called 1/0/1 where the first 1 is the chassis number.
The individual ethernet ports are not given ip addresses, it is the VLANS which have an ip address.

Back to Cisco topics