Cisco ADSL & 877 router Valid HTML 4.01!

 

Background

My 1720 router with the wic1-adsl card served me well, I cannot think of any outages I had which required a reboot of my router, a few were line related, but the 1720 recovered well.
However over time a few limitations became apparent, the wic1-adsl supports ADSL ver.1 only and the 1720 cannot support a next generation adsl modem WIC which supports ADSL2. Also, in order to get a pure ipv6 interface, I needed to add in a 10 MB/s WIC card.
The cost of a modular router such as a 1800 rack mount with the WIC2-ADSL2 card is prohibitive, but the 877 router combines all these in one box and they are available from ebay at sensible cost.
The IOS image loaded on the router was c870-advsecurityk9-mz.124-4.T2.bin, but this does not support IPv6, after some research, c870-advipservicesk9-mz.124-15.T5.bin seemed a good choice and at 18Mb in size it fitted in my flash. See the 1720 page for instructions on loading a .bin image to a Cisco router.
Building configuration...

Current configuration : 2080 bytes
!
version 12.4
no service pad
service timestamps debug datetime
service timestamps log datetime
service password-encryption
!
hostname 877-adsl
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
enable secret 5 xxxxxxxxxxxrw71
enable password 7 12334asdfsdA595451
!
no aaa new-model
!
resource policy
!
clock timezone GMT 0
clock summer-time BST recurring 4 Sun Mar 1:00 4 Sun Oct 2:00
ip cef
!
!
!
!
ip domain list rainsbrook.co.uk
ip domain name rainsbrook.co.uk
ip name-server 81.187.xx.yy
ip name-server 217.169.xx.yy
!
ipv6 unicast-routing
ipv6 cef
ipv6 multicast-routing
!
!
!
!
!
!
!
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 pvc 0/38
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
 dsl operating-mode auto
 dsl enable-training-log
 hold-queue 224 in
!
interface FastEthernet0
 description Internet LAN
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
 description ipv6 LAN
!
interface Vlan1
 description Internet LAN
 ip address 81.187.yy.zz 255.255.255.248
 ipv6 enable
!
interface Dialer0
 description WAN link to ISP
 ip address negotiated
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 ipv6 enable
 ipv6 traffic-filter adsl-ipv6 in
 ppp chap hostname user@isp
 ppp chap password 7 131asdadasd3423477B6260
!
ip route 0.0.0.0 0.0.0.0 Dialer0
!
!
no ip http server
no ip http secure-server
!
access-list 23 permit 81.187.xx.yy log
access-list 23 deny   any log
dialer-list 1 protocol ip permit
snmp-server community secret RO 23
snmp-server location LOCATION
snmp-server contact support@email.co.uk
!
!
ipv6 route ::/0 Dialer0
!
!
control-plane
!
banner login ^CC

No Unauthorized Access Allowed, Log out now!

^C
banner motd ^CCC

WARNING: No Unauthorized Access Allowed, Log out now!

^C
!
line con 0
 password 7 0er84E435sdSdsd
 login
 no modem enable
line aux 0
line vty 0 4
 privilege level 15
 password 7 02062w3424ED4150
 login
 transport input all
!
scheduler max-task-time 5000
ntp clock-period 17175143
ntp server 192.168.xx.zz
!
webvpn context Default_context
 ssl authenticate verify all
 !
 no inservice
!
end